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SHAREWARE

    This program is distributed under the Shareware concept.  You may use this
program for a period not to exceed 30 days, at which time you are expected to
register it with the authors.  If you choose not to register, you MUST
discontinue use of the program.
    By registering, you support the continued development of this and other
programs to come.
    Please feel free to make copies of this program in unmodified form only. All 
bitmaps must be included with the program in unmodified form and may not be
used or distributed separately.
 
This program is the sole property of Epsilon Computing, and may not be 
distributed along with or in connection with any other program, 
commercial, Shareware, or otherwise without the express written  consent 
of the authors.

Windows is a trademark of Microsoft Corporation.

WHAT IS SHAREWARE?

    When you buy a commercial software program, you are not just paying for
the program.  You are also paying for packaging, shrink-wrap, pre-printed
manuals, marketing, advertising, and distribution.  When you buy a commercial
program, you normally have to accept the program sight unseen, and cannot
return a program if it is not what you need.
    With Shareware programs, you are not paying for the packaging,
advertising, etc., that you do with commercial programs.  Nor do you have to
cover the costs of stocking stores and big display racks.  You have the privilege
of obtaining software for a very nominal fee (covering the cost of diskette and
copying), and trying out the program for a period of time, before actually
paying the full cost of the program itself.  When you obtain a Shareware



program, you may use the program free of charge for a reasonable period of
time, after which you are expected to 1) send payment directly to the author of
the program, or 2) discontinue use of the program.
     Shareware programs are copyrighted, full-featured programs comparable to
commercial programs.  The authors have spent many hundreds or thousands of
hours writing and perfecting their programs.  Most of the larger programs are
continually being updated with new features being added.

Shareware vendors:

    Feel free to distribute this program, in unmodified form only. You may add "help" files 
along with the program as long as the original files remain unmodified.  You must clearly state 
that the program is distributed as Shareware and that your fee is for the disk, handling, and 
copying ONLY, and that a payment to the author is required for continued use.  Fee not to exceed
$7.00.  Feel free to include this program on Shareware CD-ROMs as long as it is made clear 
that the programs on the disc are Shareware and require separate payment to the authors if 
found useful.  Contact us for the newest version.

WARRANTY

    Design-A-Room  is supplied "AS IS."  The authors make NO warranties, either
expressed or implied, including, but not limited to, fitness for particular
purpose.  The authors assume no liability for damages, direct or indirect, from
the use of   Design-A-Room.  The user assumes full responsibility for the use of
this program.

INTRODUCTION

This is a fully functional Shareware version.  It is not "crippled" in any way.  The registered
version includes several enhancements to this program.

Design-A-Room was designed to take full advantage of the benefits of Microsoft Windows. 
Practically everything that you do in Design-A-Room you do with a click of a mouse - no typing in
commands - no trying to remember strange key commands in order to do everything. About the 
only time you will need the keyboard is to type in the name of your room!

Design-A-Room lets you draw a room, put all the furniture in it, in exactly the right dimensions, 
and then move the pieces around to your heart's content-- without ever getting up from your chair!

Put walls wherever you want-- move them, resize them, make any shape and size room up to 40 
x 25 feet.  Put several rooms together on the same page - or put the same room on twice to see 
what different arrangements look like.

Design-A-Room comes loaded with 17 different wall, doors, fixtures, etc., plus 31 different 
furniture pieces.  Couches, pianos, tables, even a pool table and fireplace.! All professionally 
drawn so that you know exactly what you are looking at when you view the room. You can re-size 
each piece to the nearest inch, so you can design your room to your exact dimentions. 

The "Snap-to-Grid" option lets you quickly put your furniture and fixtures in the room. Then turn 
off "Snap-to-Grid" to let you arrange the pieces precisely where you want them. "Snap-to-Grid" 
also makes putting walls up a "snap."



Registered Version Only
**************************************************************************************************************
The "Custom Toolbar" option lets you add up to 18 of your own icons. You can create these icons 
through the program. 

The "Add Text" option lets you add text anywhere on the screen - even on top of other icons.  Text
can be added in any size using any font you have installed.  Effects such as bold, italics, 
underline, strikethru can be used.  In addition, text can be placed in any color.

The screen size has been enlarged in the registered version of Design-A-Room to let you 
increase you room sizes - this is limited only by your screen resolution. 

The dotted grid and the scales can now be turned off if desired. 

*************************************************************************************************************

Design-A-Room shows you the exact sizes of your furniture pieces, and also the exact location 
of each piece in the room to the nearest inch.  No guessing necessary!

When you are finished with your room, you can save it to disk and print it out on any  Windows 
3.1 supported printer. 

With Design-A-Room you know what your room will look like BEFORE you spend all your time 
and energy moving heavy pieces of furniture around!

Design-A-Room's intuitive interface makes rearranging furniture almost a pleasure!

Design-A-Room  comes with the following files:

SETUP.EXE - Installation program
DARSETUP.EXE - Design-A-Room Setup
DESIGN.EXE - Main program
DESIGN.INI - Configuration file
DESIGN.HLP - Help file
DESIGN.WRI - This file
DEMO.ROM - Sample room
README.TXT - Getting started information
REGISTER.TXT - Registration form
VBRUN300.DLL - Visual Basic DLL
COMMDLG.DLL - Visual Basic DLL
CMDIALOG.VBX - Visual Basic file
*.BMP - Furniture and Fixture Icons (49 files)

Installation

To install Design-A-Room, open Windows Program Manager, and select "Run" from the
"File" menu.  When prompted for the file name, type the name of the drive and 
directory the files are in and SETUP (example: A:\SETUP).

Setup will uncompress and copy the files to the proper directory and create a 
Program Manager Group and icon.



To start a room:

Measure the actual walls and furniture pieces of the room you want to design. This is the most 
critical step. The more accurate your dimensions are, the more accurate you final room will be.

When measuring, measure the length and the width, looking down from the top. When measuring
odd-sized pieces, such as a grand piano, or a round table, measure the longest dimensions each 
way. 

Start with the top wall. Click the left mouse button on the left/right wall icon to put it in the room. 
This will put the icon in the bottom right-hand corner of the room. Drag the wall icon close to the 
left-hand-side of the room. Let go of the mouse button. Then, by clicking the left mouse button 
just to the right of the icon, and holding the mouse mouse button down, drag the end on the wall 
icon to the right, watching the botton of the screen until you get to the correct length and let go of 
the mouse button. Then use the mouse to drag the piece exactly into place. The numbers at the 
bottom of the screen will show the exact position of the mouse cursor. 

Repeat the above steps to add other walls, doors, windows, and other fixtures.

To place furniture in the room:

After you have the fixtures place, add all of your furniture following the same procedure as above.
After a piece is in place, it can be easily moved to another location by dragging it, or re-sized by 
dragging just outside the icon.

To move a piece of furniture or fixture:

Simply drag it to the new location with the mouse.

To re-size a piece of furniture or fixture:

Move the cursor over the desired item.  Then, placing the mouse cursor just outside the furniture 
box, and holding the left button down, move until desired size is achieved.

To duplicate a piece of furniture or fixture:

Click on the piece of furniture with the RIGHT mouse button to select it. Go to the "Edit" menu 
and choose "Copy." Then choose "Paste." A duplicate of the piece of furniture will appear at the 
top corner of the room. Click on this piece of furniture and then move or resize it as necessary. 

To cut out a piece of furniture or fixture:

Click on the piece of furniture with the RIGHT mouse button to select.  Go to the "Edit" menu and 
choose "Cut."  Then the piece can be pasted in a new location with the "Paste" command.

To delete a piece of furniture or fixture:

Click on the piece with the RIGHT mouse button, then go to the "Edit" menu, and choose 
"Delete".

To turn "Snap-to-Grid" on or off:

Go to the "Options" menu, and click on "Snap to Grid."  This will turn "Snap-to-Grid" off. Clicking 



on it again turns it on.  With "Snap-to-Grid" on, furniture and fixtures automatically "snap" to the 
nearest grid line as they are moved or resized.  These lines are six inches apart.  With "Snap-to-
Grid" off, pieces can be moved to the nearest inch. 

To show pieces without outlines:

Go to the "Options" menu, and click on "Show Outlines."  Use "Show Outlines" to easily set up 
your room then turn them off to view the finished product.  It is much easier to set up your room 
with "Show Outlines" turned on.

To save a finished room:

Go to "File" menu and choose "Save" or "Save As."  "Save" will save the current room with the 
current filename. "Save As" will let you save the file under a different name.

Design-A-Room automatically adds the extension "ROM" to all saved room files. 

To load a previously made room:

Click on the "File" menu. Choose "Open."  Click on the the desired file, and then click on "OK."

Note: This version of Design-A-Room introduces a new, enhanced file format.  It will read files 
from all previous versions and, when they are saved, they will be saved in the new format.

To start a new room:

Click on the "File menu. Choose "New." 

To print the room:

From the "File" menu, choose "Print."

To exit the program:

From the "File" menu, choose "Exit."

REGISTRATION

When you register this program, you will receive the newest version of Design-A-Room without 
the Shareware Screen, registered in your name, and  a 1 month free membership on the Epsilon 
Computing Board (513) 563-6475. Registered users also are eligible to purchase future updates 
and future products at half price!

The registered version of Design-A-Room supports room sizes limited only by 
your screen resolution (62 X 45 feet in 1024x768 resolution).  It includes a third, 
user-customizable toolbar for your own icons which can easily be created and 
edited without leaving the program.  Also, text can be placed anywhere on the 
screen for titles, labels, notes, and more.  In addition, the background grid and 
scales can be turned on and off.

To register, either call (513) 563-4871 with your Visa or MasterCard handy, or print out 



REGISTER.TXT and mail it along with $19.95 (+ 5.5% tax if in the state of Ohio) to:

                                           Epsilon Computing 
                                          1668 Trillium Court
                                         Cincinnati, OH 45215

You can also register online by calling The Epsilon Computing Board at (513) 563-6475 (2400-
38400 BPS/HST/V.32bis) anytime with you Visa or Mastercard number handy.

We can be reached for questions, comments, etc.
at the above address or- 
by calling (513) 563-4871
by calling The Epsilon Computing Board at (513) 563-6475 (our BBS)
by Netmail to Scott Mace or Bob Mace at Net/Node 006/042 on the GT Power Network
on CompuServe (user ID: 72712,2320) or 
on Internet (macers@ctrvax.vanderbilt.edu).  

Call The Epsilon Computing Board to download the latest version.

Thank you for trying Design-A-Room  !


